Telefonszámunk: 1-472-0679

[Resolved] Adatok összevonása több oldalról egy oldalra

Kezdőlap Fórumok Excel témák [Resolved] Adatok összevonása több oldalról egy oldalra

Topic Resolution: Resolved

Ennek a témakörnek tartalma 3 hozzászólás, 3 résztvevő. Utolsó frissítés:  weasleyrat 1 hét, 5 napja telt el a bejegyzés óta.

4 bejegyzés megtekintése - 1-4 / 4
  • Szerző
    Bejegyzés
  • #4134

    weasleyrat
    Résztvevő

    Sziasztok!

    A következő kérdéssel fordulnék hozzátok:

    A mellékelt táblázatban található 3 dátum fül (egy teljes táblázatban a hónap összes munkanapjával), ahol részletezve vannak az adatok. Ezen kívül található még egy összegzés fül, ahol a városokhoz tartozó százalék adatot kell összegezni.

    Tudnátok segíteni egy olyan megoldásban, hogy ne kézzel kelljen másolgatni ennyi adatot, hanem a táblázat magától pakolja át?

    Előre is köszönöm a segítséget!

    Üdvözlettel,
    Péter

    Attachments:
    You must be logged in to view attached files.
    #4136

    horvimi
    Kulcsmester

    Szia!

    Próbálok udvariasan fogalmazni, mert amikor megláttam fájl tartalmát, sok minden eszembe jutott … 🙂
    Szóval egy ilyen adatszervezéssel, ami enyhén szólva alulstruktúrált, összesítési feladatokat csak fáradtságos kézi munkával lehet csinálni. Aztán talán lehet rá írni egy makrót, ami talán még működik is, ha a városnevekhez képest valahogy biztosan megtalálható az a bizonyos cella, amiben a hozzájuk tartozó százalékok vannak.

    De néha az adatbevitel egyszerűen tartása miatt (szépen látszódik minden város külön táblázatrészben), szembe kell nézni a szívással, ami az összesítést illeti.

    Azért konstruktív ötletem is lenne:

    Ha az én feladatom lenne, akkor dühömben a következőt csinálnám
    1. Minden lapon csinálnék egy városonkénti kigyűjtést Ha a munkalapok azonos felépítésűek, ugyanazokkal a városokkal és a városokhoz tartozó összesítő cellák is ugyanott vannak, akkor ez elég gyorsan megvan, mert másolható. (Ez a három lapon igaz volt)

    2. Az összesítő lapon felírnám az első oszlopba az összes munkanapot az adott hónapban, az első sorba az összes várost. A módszer kihasználja, hogy a dátumok a munkalapok nevei, tehát nem dátumokat írok, hanem a munkalapok neveit.

    3. Egy elég bonyolult képlettel behivatkoznám az egyes lapokról az 1. lépésben kigyűjtött százalék értékeket.

    Megcsináltam, visszatöltöttem, nézd meg!

    Imre

    Attachments:
    You must be logged in to view attached files.
    #4138

    Csaba001
    Résztvevő

    Az “Összegzés” lapon a B2 cellába: =HA(A2=””;””;INDIREKT(KÖZÉP(SZÖVEG(A2;”éééé.hh.nn”);6;5)&”!$g$16″;IGAZ))

    • A hozzászólás módosításra került: 1 hét, 5 napja telt el a bejegyzés óta- Csaba001.
    #4140

    weasleyrat
    Résztvevő

    Sziasztok!

    Köszönöm a megoldásokat, remekül működnek!

    Üdvözlettel,
    Péter

4 bejegyzés megtekintése - 1-4 / 4

Be kell jelentkezni a hozzászóláshoz.