Telefonszámunk: 1-472-0679

[Resolved] Darab2 függvény feltunningolva

Kezdőlap Fórumok Excel témák [Resolved] Darab2 függvény feltunningolva

Topic Resolution: Resolved

Ennek a témakörnek tartalma 9 hozzászólás, 4 résztvevő. Utolsó frissítés:  horvimi 1 hét, 2 napja telt el a bejegyzés óta.

10 bejegyzés megtekintése - 1-10 / 10
  • Szerző
    Bejegyzés
  • #4814

    dani
    Résztvevő

    Sziasztok!

    Van tippetek a következőre? Adott mondjuk az A függőleges táblázat, melyben darab2 függvénnyel tartom számon, hogy mennyi bejegyzéssel nő a számuk A1-től mondjuk A200-ig, ez eddig ok, viszont az A táblázaton belül vannak kategória elnevezések pl édesség, borok stb és mivel azokat a cellákat is bejegyzésnek érzékeli ezért beleszámolja az összesbe. Hogy lehetne azt a néhány cellát eliminálni?

    köszönettel,
    Dénes

    #4815

    mravi
    Résztvevő

    Ilyenre gondoltál?

    Attachments:
    You must be logged in to view attached files.
    #4817

    dani
    Résztvevő

    Szia!

    Köszi a tippet. Csatoltam az általad küldött Excelt, melybe beleírtam, hogy pontosan mire gondolok…

    Attachments:
    You must be logged in to view attached files.
    #4819

    mravi
    Résztvevő

    =DARAB2(M9:M98)-2
    Ha csak az a baj hogy azt is számolja akkor azt a két cellát csak ki kell vonni.

    #4820

    mravi
    Résztvevő

    Vagy pl:
    =DARAB2(M9:M17;M19:M29;M31:M49)

    #4821

    dani
    Résztvevő

    Átírtam az általad ajánlottra, de hibát észlelt, felajánlott javítást, elfogadtam, de továbbra sem mutatja a helyes értéket.
    Nézd csak…

    Attachments:
    You must be logged in to view attached files.
    #4823

    mravi
    Résztvevő

    Nálam jól működik az amit küldtél.

    #4824

    delila
    Résztvevő

    Az R8 cella eredménye nem tetszik? Oda nem DARAB2, hanem DARABTELI függvény kell.
    =DARABTELI(M:M;”x”)

    #4825

    mravi
    Résztvevő

    A darab2 függvény is jó főleg akkor ha nem csak x van a cellában (x lehet hogy csak példa). Ha változó tartalmat kell számolni akkor a darab2 a jó ha pedig kritérium szerint van akkor a darabteli.

    #4826

    horvimi
    Kulcsmester

    Gondolom az a cél, hogy bármennyi alkategória lehessen.
    Ha már így struktúrálod az adatokat és nem teszed külön oszlopba a kategória neveket, akkor viszont meg kell különböztetned az alkategóriákat a többi bejegyzéstől, amiket x-el jelöltél.

    Például a végükre írnék egy spec karaktert, mondjuk egy kötőjelet. (Édesség -, Borok -, Testápolók -, stb…)
    Majd az összes kitöltött cella számából kivonjuk a kötójelre végződők számát.
    És akkor a képlet így nézne ki:

    =DARAB2(M9:M98)-DARABTELI(M9:M98;"*-")

    Imre

    • A hozzászólás módosításra került: 1 hét, 2 napja telt el a bejegyzés óta- horvimi.
10 bejegyzés megtekintése - 1-10 / 10

Be kell jelentkezni a hozzászóláshoz.