Telefonszámunk: 1-472-0679

[Resolved] Keresés másik munkalapon és adat átírás

Kezdőlap Fórumok Excel témák [Resolved] Keresés másik munkalapon és adat átírás

Topic Resolution: Resolved

Ennek a témakörnek tartalma 12 hozzászólás, 2 résztvevő. Utolsó frissítés:  horvimi 2 hónapja, 2 hete telt el.

13 bejegyzés megtekintése - 1-13 / 13
  • Szerző
    Bejegyzés
  • #5786

    biopityu1
    Felhasználó

    Sziasztok!
    Excel segítséget kérnék!
    Van egy táblázatom, 2 munkalappal. Munkalap1(ami a raktárkészlet 220000 sorral) és Munkalap2(ami a speciális szűrés eredménye, kb 100000 sorral). Munkalap2-ben levő adatok alapján kell keresnem és a keresés alapján adatokat kiszedni Munkalap1-ből és átírni Munkalap2-be..
    Szóval..
    Munkalap2-ben szeretnék egy olyan függvényt, ami megkeres egy Munkalap2-ben levő számot Munkalap1-ben, és ha megtalálta, akkor a Munkalap1-ben lévő számhoz tartozó sor egy másik oszlopának adatát átírná Munkalap2-be. Például Munkalap2 N34-es cella tartalmazza a 41514 számot. Ezt a számot kellene megkeresni Munkalap1-ben, ha megtalálta, a hozzá tartozó, de S oszlopban levő eredményt írná ki nekem Munkalap2-be.
    köszönöm előre is

    #5787

    horvimi
    Adminisztrátor

    Ezt csinálja az FKERES vagy angolul a VLOOKUP függvény

    #5788

    biopityu1
    Felhasználó

    igen. azzal próbálkozok, de valamiért vagy HIBA vagy NÉV vagy HIÁNYZIK az eredmény..:D

    #5789

    horvimi
    Adminisztrátor

    Ha a szemeddel vagy kereséssel megtalálod, de az FKERES nem találja, akkor a két lapon nem teljesen egyforma az adat.

    Ha leirnad ide a.kepletet, az segithetne.

    Imre

    #5790

    biopityu1
    Felhasználó

    oké és köszönöm hogy foglalkozol a problémámmal!
    Szóval munkalap1(raktár) A2-től S25000-ig tart. Amit keresek, az az N oszlopban van és ha megtalálja, akkor a hozzá tartozó I oszlop eredményét szeretném megkapni..

    =FKERES(Q2;Raktár!N2:S25042;1;Raktár!$I$2)

    #5791

    biopityu1
    Felhasználó

    ez úgy néz ki jó..
    =FKERES(Q2;Raktár!N2:S25042;2;0)

    #5792

    horvimi
    Adminisztrátor

    Ha az N oszlopban keresel, ea az I oszlopbol akarsz visszakapni adatot, azaz balról, az FKERES nem fog menni.

    A te kepleted, amit jónak mondasz, az N oszlopban keres, es az O oszlopbol ad vissza eredményt.
    Mivel a megadptt keresési tabla második oszlopa az N utáni, tehát az O oszlop.

    Ha ezt akartad, akkor ok.

    #5793

    biopityu1
    Felhasználó

    =FKERES(Q2;Raktár!N2:S25042;2;0)
    szerintem ez jó, úgy néz ki 🙂
    az átirandó értéket átraktam O oszlopba hogy jó legyen, de csak 15000 sorig csinálja meg. utána Hiányzik hiba van, pedig benne van a táblázatban a keresett adat..

    • A hozzászólás módosításra került: 2 hónapja, 2 hete telt el- biopityu1.
    #5795

    horvimi
    Adminisztrátor

    A képletben a keresési táblát le kel rögzíteni ($)

    #5796

    biopityu1
    Felhasználó

    =FKERES(Q15261;Raktár!$N$15261:$S$40301;2;0)
    erre gondoltál?
    így is azt írja ki, hogy HIÁNYZIK.. PEDIG az első munkalapon szerepel..
    Mi lehet a gond?

    #5797

    horvimi
    Adminisztrátor

    Az elso keplet a tetején, a második sorban legyen ez:

    =FKERES(Q2;Raktár!$N:$S;2;0)

    Azza teljes oszlopokat adunk meg keresesi tablanak.

    Ezt másold lefelé

    #5798

    biopityu1
    Felhasználó

    Megoldódott, nagyon nagyon köszönöm! 10 óra munka kész 20 perc alatt! Szuper vagy!!!

    #5800

    horvimi
    Adminisztrátor

    Szívesen

13 bejegyzés megtekintése - 1-13 / 13

Be kell jelentkezni a hozzászóláshoz.