Telefonszámunk: 1-472-0679

[Resolved] Segítséget kérnék

Kezdőlap Fórumok Excel témák [Resolved] Segítséget kérnék

Topic Resolution: Resolved

Ennek a témakörnek tartalma 2 hozzászólás, 2 résztvevő. Utolsó frissítés:  Milvus 6 hónapja, 2 hete telt el.

3 bejegyzés megtekintése - 1-3 / 3
  • Szerző
    Bejegyzés
  • #5706

    Milvus
    Felhasználó

    Sziasztok, egy kis segítségre lenne szükségem!

    Olyan problémára keresnék megoldást vagy valami függvényt, hogy van egy nagyon hosszú adatsorom (kb 3 millió adat), dátumokból áll és az adott dátumnál értékekből.

    Na mármost, az a problémám, hogy néhány dátum értéknél ahol hiba miatt 0-at írtam be most megkaptam a jó értékeket ez úgy pár 10 ezer szám és nem igazán szeretném egyesével beírni őket a nagy adatsorba.

    Van valami olyan függvény ami, össze tudja rántani az értékeket anélkül, hogy a többit összekavarná?

    Részletet iderakok hogy jobban érthető legyen:

    2017.01.07 12:00 0,000 2017.01.07 12:00 4,656

    2017.01.07 12:05 0,000 2017.01.07 12:05 4,740

    2017.01.07 12:10 0,000 2017.01.07 12:10 4,752

    2017.01.07 12:15 0,000 2017.01.07 12:15 4,824

    2017.01.07 12:20 0,000 2017.01.07 12:20 4,932

    2017.01.07 12:25 0,000 2017.01.07 12:25 4,956

    2017.01.07 12:30 0,000 2017.01.07 12:30 4,032

    2017.01.07 12:35 3,780 2017.01.07 12:40 4,248

    2017.01.07 12:40 0,000 2017.01.07 12:45 4,632

    2017.01.07 12:45 0,000 2017.01.07 12:50 4,620

    2017.01.07 12:50 0,000 2017.01.07 12:55 4,452

    2017.01.07 12:55 0,000 2017.01.07 13:00 4,656

    2017.01.07 13:00 0,000

    Az első oszlop, amiben a sok nulla van oda kéne beilleszteni az adatokat, csak problémába ütköztem mert bár nem a legjobb részletet másoltam ki de látszik hogy van a nullák között érték is és eddig akárhogyan próbáltam bemásolni az adatokat eltolódott az egész mert arra a helyre is bemásolt valamit ahol eddig is volt érték a példa esetén 12:35-re bemásolta 12:40-es értéket és így már eltolódott az egész.

    És az új adatokból meg nem is minden napra van érték 7.-e után 20.-án van újra értékem és azt is folytatólagosan másolta be 8.-ára és így tovább.

    Tehát valaki tudna segíteni abban, hogy ha pontosan egyezik a két dátum akkor vegye az új értéket, és alkalmazni lehessen egy teljes oszlopra mert egyesével beírogatni a függvényt kb 30 ezer alkalommal nem bírnám.

    Előre is köszi a segítséget!

    #5707

    Titok
    Felhasználó

    Plusz oszlop. (Pl a dátum A oszlop, az érték B oszlop, akkor C oszlopba beírod:
    =HAHIBA(FKERES(A2,TartományA:B!,2,0),B2)
    Vagyis ha nem leli az új adatok között, akkor beírja az eredeti értéket. A vessző pontosvessző, csak ebbe a szarba már megint eltünt.

    #5708

    Milvus
    Felhasználó

    Köszi, a választ sikerült megoldani a problémát.

3 bejegyzés megtekintése - 1-3 / 3

Be kell jelentkezni a hozzászóláshoz.