Telefonszámunk: 1-472-0679

[Resolved] Státusz nyilvántartás legördülő listával és időbélyegzéssel

Kezdőlap Fórumok Excel témák [Resolved] Státusz nyilvántartás legördülő listával és időbélyegzéssel

Topic Resolution: Resolved

Ennek a témakörnek tartalma 2 hozzászólás, 2 résztvevő. Utolsó frissítés:  Csaba 3 hónapja, 1 hét telt el.

3 bejegyzés megtekintése - 1-3 / 3
  • Szerző
    Bejegyzés
  • #5434

    Csaba
    Felhasználó

    Sziasztok,

    Kérdés:
    Ez egy státusz nyilvántartás táblázat Google Sheet-ben:
    az lenne a feladat, hogy amikor kapok egy megrendelést, akkor nyomon követem annak menetét időbélyegzéssel, a státuszokat legördülő listából lehet kiválasztani, és ettől a választott elemtől függően írja be az időértéket a képlet a megadott cellába.
    Ha függvénnyel szeretném megoldani, akkor a Most() függvény minden egyes cellabeírás miatt újra tölti az időértékeket, sajnos

    így néz ki, de tudok Google Drive linket is küldeni
    A C oszlopban van a legördülő lista
    saját sorszám vevő neve esemény megrendelést kaptam szállítás teljesítve számlát elküldtem számla fizetve
    1 AA megrendelést kaptam 2018.12.13. 18:16:51 0 0 0
    2 BB megrendelést kaptam 2018.12.13. 18:16:51 0 0 0
    3 CC megrendelést kaptam 2018.12.13. 18:16:51 2018.12.13. 18:01:58 0 0
    4 DD szállítás teljesítve 2018.12.13. 17:55:56 2018.12.13. 18:16:51 2018.12.13. 18:02:12 0
    5 EE számlát elküldtem 2018.12.13. 17:55:57 2018.12.13. 18:02:46 2018.12.13. 18:16:51 2018.12.13. 18:02:20

    A képlet: D2=HA(D2<>””;HA(C2=$I$1;MOST();D2);””)
    A körkörös hivatkozás miatt: Fájl menű > A táblázat beállítása > Számítás fül > Iteratív számítás: Az iterációk maximális száma: 5-re állítani

    Nektek milyen megoldásotok lenne erre a feladatra?

    Segítségeteket előre is köszönöm
    üdv
    Kozma Csaba

    #5436

    horvimi
    Adminisztrátor

    Szia!

    Ebben a fórumban nem foglalkozunk Google Spreadsheet kérdésekkel.
    Ez egy Excel fórum.

    De szerintem ez egy eseménykezelési probléma.
    Google docs nyelven Trigger.
    Kezd el tanulmányozni az Apps Scriptet.
    https://developers.google.com/apps-script/overview

    Van egy olyan esemény, hogy onEdit(e).

    Akkor fut, ha egy cella értéke megváltozik.
    Az e-ben van, hogy melyik cella. Excelben is hasonlóan van.

    Tehát tudod, hogy melyik cella változott, és mi volt a régi értéke, mi lett az új értéke, ergo tudsz döntést hozni, hogy melyik más cella értékét változtatod. És ráadásul az időbélyeget nem függvénnyel, hanem értékként tudod beírni, ami megszünteti az állandó újraszámolást.

    Imre

    #5437

    Csaba
    Felhasználó

    Szia Imre,
    nagyon köszönöm az e-mailt, megnézem az ajánlott linket
    ((ott neked a “noreply” címre nem tudtam válaszolni))
    üdv
    Csaba

3 bejegyzés megtekintése - 1-3 / 3

Be kell jelentkezni a hozzászóláshoz.