Telefonszámunk: 1-472-0679

Több munkalapon való szűrés

Kezdőlap Fórumok Excel témák Több munkalapon való szűrés

Ennek a témakörnek tartalma 3 hozzászólás, 4 résztvevő. Utolsó frissítés:  horvimi 2 hónapja, 2 hete telt el.

4 bejegyzés megtekintése - 1-4 / 4
  • Szerző
    Bejegyzés
  • #5476

    mfranci
    Felhasználó

    Kedves excel tudósok!
    A kérdésem az lenne, hogy van egy óriási 60 munkalapból álló lista és szeretném az adategyezéseket leszűrni egy 61. listához képest.
    Tehát 60 oldalas a raktárkészlet és van egy külön lista,arra lennék kíváncsi hogy a 60 oldalon hol találhatóak meg a külön lista tételei.
    Várom válaszukat!

    #5477

    delila
    Felhasználó

    Vegyük azt az egyszerű esetet, hogy mind a 61 lapon az A oszlopban vannak a tételek, és az A1 cella oszlopcím.
    A 61. lapon a B1:BI1 cellákba írd be a 60 lap nevét (Munka1; Munka2).

    Ezen a lapon a B2 cella képlete
    =HAHIBA(HOL.VAN($A2;INDIREKT(B$1 & “!A:A”);0);”–”)
    ezt másolhatod jobbra, és le. Az eredmény az egyes lapokon megtalálható tétel sorának a száma.

    #5480

    Titok
    Felhasználó

    Qurybe lehet ilyet, de ahhoz nem annyira értek.
    De azt megteheted, ha nem túl sok sorod van, hogy csinálsz egy hivatkozást az összesítő lapra (pl mindegyik munkalap 1000 sorára). Ebben lesz sok 0 adat is, de ha erre ráraksz egy kimutatásvarázslót, akkor látsz majd mindent.
    De ez elég fapados megoldás.

    #5484

    horvimi
    Adminisztrátor

    Mfranci kérdéséhez:

    Nem teljesen egyértelmű a szűrés/keresés alapja és hogy mit szeretnél eredményként látni.

    – Mi alapján döntöd el, hogy egyezés van-e (Azonosító, Név, esetleg mindkettő)
    – A 61. listán a tételek mellett legyen ott, hogy melyik lapon, hol találta meg, vagy csak az, hogy megtalálta-e bármelyiken?
    – Előfordulhat-e, hogy több lapon is megvan ugyanaz az azonosító?
    – Mi a végcélod? Esetleg egy letisztázott, egy lapos lista, amin nincsenek ismétlődések?

    Várom válaszod,

    Imre

4 bejegyzés megtekintése - 1-4 / 4

Be kell jelentkezni a hozzászóláshoz.