Telefonszámunk: 1-472-0679

[Resolved] Kisebb – nagyobb probléma

Kezdőlap Fórumok Excel témák [Resolved] Kisebb – nagyobb probléma

Topic Resolution: Resolved

Ennek a témakörnek tartalma 1 hozzászólás, 2 résztvevő. Utolsó frissítés:  horvimi 1 hónap, 2 hete telt el.

2 bejegyzés megtekintése - 1-2 / 2
  • Szerző
    Bejegyzés
  • #7315

    Bmike
    Felhasználó

    Van egy táblázatom repülőjáratokról, ahol szeretném összeszámolni, hogy milyen hosszú járatokból hány darab van. Viszont se a Darabtelivel, se a Darabhatöbbel nem tudok eredményre jutni. Ezeket próbáltam meg:
    KÉP>
    =DARABTELI(‘Routes (S20 July)’!$U$2:$U$1100;ÉS(>A1;<=B1))
    =DARABHATÖBB(‘Routes (S20 July)’!$U$2:$U$1100;>A2;’Routes (S20 July)’!$U$2:$U$1100<=B2

    • A témakör módosításra került: 1 hónap, 2 hete telt el- Bmike.
    • A témakör módosításra került: 1 hónap, 2 hete telt el- horvimi.
    #7319

    horvimi
    Adminisztrátor

    Szia!

    A megoldáshoz azt kell tudnod, hogy ezek a függvények a feltételt mindenképpen szöveges formában várják.
    Elég béna, de így van.

    Emiatt a DARABTELI-s megoldás kísérlet eleve nem fog menni, mert az ÉS függvény logikai kimenetet ad.
    Ha a feltétel nem egyenlőség, hanem egyenlőtlenség egy cella tartalmával, akkor meg kell oldani, hogy szöveges legyen a feltétel. Ezt így szoktuk:

    =DARABTELI(A1:A10;">"&C2)

    Ez megmondja, hogy az A1:A10 tartományban hány olyan érték van, ami nagyobb, mint a C2-ben lévő.

    Ebből kiindulbóva a DARABHATÖBB függvényed meggyógyítható.

    =DARABHATÖBB(‘Routes (S20 July)’!$U$2:$U$1100;">"&A2;’Routes (S20 July)’!$U$2:$U$1100;"<="&B2)

    Imre

2 bejegyzés megtekintése - 1-2 / 2

Be kell jelentkezni a hozzászóláshoz.