Telefonszámunk: 1-472-0679

Kezdőlap Fórumok Excel témák Datumok közti adott napokra valo szüres Hozzászólás: Datumok közti adott napokra valo szüres

#6153

horvimi
Adminisztrátor

Kérdés, hogy a tól-ig dátumokat ebben a formátumban, hogy dd.mm.yyyy az Excel dátumként, vagy szövegként ismeri fel?
Ha nem, akkor az első feladat a szöveges dátumok igazi dátummá alakítása.

Ezeket adottnak tekinthetjük.

A megoldás valami hasonló lehet egy sorban:
1. Képezzük a szabi kezd és vég közötti összes dátumot tartalmazó tömböt
2. megnézzük minden elemére, hogy a vizsgált intervallumba esik-e, ha igen, akkor 1, ha nem, akkor 0
3. összeadjuk az 1-eseket.
4. lehúzzuzk az összes sorra.
5. az így kapott oszlopot szummázzuk, hogy a teljes állományra megkapjuk az összeget

Ez egy elég bonyolultnak tűnő tömbképlet, de működik.

=SZORZATÖSSZEG(--(SOR(INDEX($A:$A;B7):INDEX($A:$A;C7))>=$F$2)*--(SOR(INDEX($A:$A;B7):INDEX($A:$A;C7))<=$G$2))

Csatoltam

Imre

Attachments:
You must be logged in to view attached files.