Telefonszámunk: 1-472-0679

Hozzászólás: Táblában max érték sorának és oszlopának keresése

Kezdőlap Fórumok Excel témák Táblában max érték sorának és oszlopának keresése Hozzászólás: Táblában max érték sorának és oszlopának keresése

#2585
horvimi
Adminisztrátor

    Szia!

    Nagyon érdekes problémákat hozol. Először azt hittem, passzolnom kell, mert nem nagyon volt ötletem, és nem is nagyon találtam megoldást. Végül meglett, sé kiderült, hogy elsőre elég közel jártam.

    Szóval tegyük fel, hogy a tartományod az A1:D4-ben van.
    Max érték koordinátái feladat

    1. Tömbképlettel megnézheted, hogy hol van benne a legnagyobb érték:
    =--(A1:D4=MAX(A1:D4))
    Ez egy tömböt ad eredményül. Ott lesz benne egy egyes, ahol a legnagyobb érték van.

    2. Ha ezt szorzod a tartomány celláinak az oszlopaival, akkor az eredmény mátrixban az adott helyen a keresett max érték oszlopának száma lesz, a többi helyn meg nulla.

    3. Ezt a szorzatösszeggel összeadva, megkapható eredményként a max érték oszlopának száma száma
    =SZORZATÖSSZEG(--(A1:D4=MAX(A1:D4))*OSZLOP(A1:D4))

    4. A fejlécből kiveszed az ennyiedik elemet

    5. Ugyanezt megcsinálod a sorokra is.

    6. A két képletet egybe is vonhatod, hogy a sor és oszlop számítás, meg az INDEX függvények ne legyenek külön cellákban.

    Max érték koordinátái megoldás

    FONTOS!
    Ez nyilván csak akkor műxik, ha nincs két egyforma legnagyobb.
    Különben PASSZ!

    Visszatöltöttem a fájlt a megoldással.

    Imre

    • A hozzászólás módosításra került: 8 years, 2 months telt el-horvimi.
    • A hozzászólás módosításra került: 8 years, 2 months telt el-horvimi.
    Attachments:
    You must be logged in to view attached files.