Telefonszámunk: 1-472-0679

Hibaüzenetek lecserélése – Hibakezelés

2013-02-21 - horvimi - Megtekintések száma: 759 - Kategória: Képletek, Szerkesztés
Hivatkozott Excel verzio: Excel 2007 Excel 2010 Excel 2013

Ha adott egy olyan Excel tábla, amelyben a képletek hibaüzeneteket adnak vissza, felmerülhet az igény a hibaüzenetek megváltoztatására, törlésére.

Ezzel kapcsolatban már volt egy korábbi anyag, amelyben az IFERROR (HAHIBA) függvényt mutattuk be, ami pont erre való. De mit tehetünk akkor, ha már adott a hibákat tartalmazó táblázat, és a képletekhez nem nyúlhatunk?

Segéd oszlopban, külön képlettel vizsgáljuk a hibát, és ha fennáll, egyéb értéket adunk, különben megtartjuk az eredeti eredményt. A képen látható példában a hibaüzenetet nullára cseréljük.

A képlet angol verzióhoz

=IF(ISERROR(B2);0;B2)

A képet magyar verzióhoz

=HA(HIBÁS(B2);0;B2)

Ezt a megoldást akkor érdemes használni, ha a tráblázathoz új sorok is adódhatnak, és a hibakezelés képletet csak le kell húzni és kész.

Hibaüzenetek cseréje speciális kijelöléssel

  1. Válasszuk a speciális (irányított) kijelölést: F5->Special… (Irányított…)
  2. Jelöljük be azt, hogy képleteket, azon belül hibákat keresünk. Ez kijelöli az összes hibaüzenetet, ezek közül az elsőben lesz az aktív cella
  3. Gépeljük be azt az értéket, amit a hibák helyett látni szeretnénk, pl.: nulla
  4. Ctrl+ENTER-rel zárjuk le, ami az össze kijelölt cellába ugyanazt az értéket viszi be.

Mindez animációban

Vélemény, hozzászólás?