Telefonszámunk: 1-472-0679

[Resolved] Ár növelése

Kezdőlap Fórumok Excel témák [Resolved] Ár növelése

Topic Resolution: Resolved
6 bejegyzés megtekintése - 1-6 / 6
  • Szerző
    Bejegyzés
  • #9007
    BraveHeart
    Felhasználó

    Sziasztok,

    Adott egy szép nagy Excel tábla.
    A feladat a következő lenne példaként.

    A1 cellában szerepel a jelenlegi önköltség, B1 cellába kerül az emelt önköltség és a C1 cellába a kettő százalékos változása. D1 egy cellában a jelenlegi ára szerepel a terméknek.
    Amit szeretnék: hogy az E1 cellában meg lehet-e azt csinálni azt, hogy ha a C1 0-5% között van akkor pl. 7%-al emelkedjenek az árak, de ha 5-10% között van akkor pl. 12% szorozza fel az D1 cella értékét.

    Remélem érthetően írtam le a dolgot igyekeztem egyszerűen megfogalmazni.

    Köszönöm

    #9012
    horvimi
    Adminisztrátor

    Szia!

    A feladat többféleképpen is megoldható, én most egy HA + ÉS fv megoldást mutatnék.

    =HA(ÉS(C1>=0;C1<5%);D1*(1+7%);HA(ÉS(C1>=5%;C1<10%);D1*(1+12%);D1*(1+15%)))

    Ez egy háromszoros elágazás. Azt nem írtad, hogy az felsorolt eseteken kívüli esetbe mi történjen, ezért én önhatalmúlag 15%-os növekedést írtam elő.

    Balról jobbra haladva:

    Ha C1 0 és 5% közé esik (azaz nagyobb vagy egyenlő nulla ÉS kisebb mint 5%), akkor az eredmény legyen a D1 szorozva 1+7%, azaz D1*1,07.
    Különben HA 5 és 10% közé esik (a vizsgálat ugyanúgy megy ÉS függvénnyel), akkor D1*1,12
    Ha egyik sem, akkor D1*1,15

    Imre

    • A hozzászólás módosításra került: 2 weeks, 5 days telt el-horvimi.
    #9014
    BraveHeart
    Felhasználó

    Szia,

    Köszönöm szépen sikerült 🙂

    #9015
    horvimi
    Adminisztrátor

    Örülünk! 🙂

    #9020
    BraveHeart
    Felhasználó

    Szia,

    Tökéletesen működik még egy kicsit tovább is fejlesztettem 🙂 kísérleteztem 🙂

    Ugyanehhez a táblázathoz lenne egy kérdésem.
    Azt meg lehet-e oldani, hogy havonta egyszer egy bizonyos dátumra beállítva akkor a D oszlopban lévő értékeket átmásolja mondjuk az E oszlopba.

    Köszönöm

    #9021
    delila
    Felhasználó

    Szia!

    A ThisWorkbook laphoz rendeld a makrót. A csillagozott sorban állíthatod be, hogy melyik napon másoljon.

    Private Sub Workbook_Open()
        If Day(Date) = 10 Then  '*********
            Columns(4).Copy
            Range("E1").PasteSpecial xlPasteValues
        End If
    End Sub

    Azt biztosan meg tudod adni, hogy ha a hónap megadott napja hétvégére esik [WeekDay(Date,2]>5, akkor a következő hétfőn másoljon.

6 bejegyzés megtekintése - 1-6 / 6
  • Be kell jelentkezni a hozzászóláshoz.