Telefonszámunk: 1-472-0679

[Resolved] Számsorok keresése

Kezdőlap Fórumok Excel programozás [Resolved] Számsorok keresése

Topic Resolution: Resolved
4 bejegyzés megtekintése - 1-4 / 4
  • Szerző
    Bejegyzés
  • #9023
    Argos78
    Felhasználó

    Sziasztok !
    Segítséget szeretnék kérni.
    Van egy munkafüzet melyben soronként 20 szám szerepel ,a számok külön cellában kb 500sor
    Egy oszlop kimarad és utánna 5szám soronként szintén egy szám egy cella .
    Itt kb 1000 sor van .
    Azt szeretném ha az 5 számból álló sor megvan mundjuk 10x a 20számból álló sorokban úgy hogy egy sorban mind az 5szám szerepel akkor írja a következő cellába az eredményt .pl;mondjuk ez egy sor
    2 5 6 8 27 az eredmény 5
    Tehát ez az 5 szám az 500 sorban 5x van még úgy hogy mind az 5 megtalálható egy sorban .
    Köszönöm a segítséget!

    #9030
    horvimi
    Adminisztrátor

    Szia!

    Gyönyörű feladat! Csak azt kellene eldöntened, hogy 10x meglévőket vagy 5x meglévőket keresel 🙂

    Excel függvényekkel egy lépésben nem is valósítható meg.

    Egyik lehetőség, hogy makróprogramot kell rá írni.

    Másik lehetőség a tömbképletek használata, és még így is több lépésre van szükség

    A B2:U2-ben van 20 szám, a W2:AA2-ben 5 szám.
    Arra vagyunk kíváncsiak, hogy az 5-ből hány van benne a 20-ban.

    =SZORZATÖSSZEG(DARABTELI(B2:U2;W2:AA2))

    Ezt a 20 számos tartomány minden sorára meg kell nézni, tehát a B2:U2 mozog, a W2:AA2 nem mozog.
    Kapsz annyi eredményt, ahány sora van a 20 számos tartománynak, majd egy ellenőrző cellában megnézed, hogy hány olyan van, ami =5.
    Ezzel kész vagy az első 5 számos húzás elemzésével.

    És a fentieket meg kell csinálni az 5 számos tartomány minden sorára.

    Segítséget kértél, íme a módszertan.

    Imre

    #9032
    Argos78
    Felhasználó

    Kedves Imre!
    Az 5x és a 10x csak példa volt ..nem azt keresem ami pont annyiszor van meg! Hanem hogy melyik hányszor !
    Jól látod makró kell hozzá ..
    Excel programozásban indítottam ezt a kis problémát .
    Nem manuálisan szeretném megoldani mert az hosszú idő lenne .
    Azért köszönöm a módszertant!
    Üdv Roland

    #9033
    horvimi
    Adminisztrátor

    Kedves Roland!

    Nem kell hozzá feltétlenül makró.
    Csatoltam egy demót natív Excel eszközökkel.

    A makró megírása tervezéssel, tesztelgetéssel több órányi feladat lehet, annyi nekem most nincs, de ha a makrós megoldást szeretnéd, szívesen segítek, ha elindultál már valamerre és elakadtál.

    A fenti módszertan egyben az algoritmusa is a makrónak.

    Imre

    Attachments:
    You must be logged in to view attached files.
4 bejegyzés megtekintése - 1-4 / 4
  • Be kell jelentkezni a hozzászóláshoz.