Telefonszámunk: 1-472-0679

Tartomány minden eleme egyenlő?

2014-01-19 - horvimi - Megtekintések száma: 731 - Kategória: Képletek, Tömbképletek
Hivatkozott Excel verzio: Excel 2007 Excel 2010 Excel 2013

Egy nagyon ötletes képletet szeretnék mutatni, amivel azt lehet megvizsgálni, hogy egy tartomány minden eleme azonos-e vagy sem.

Legyen a vizsgált tartomány az A1:F1 tartományban

=AVERAGE(COUNTIF(A1:F1;A1:F1))=COUNTA(A1:F1)
=ÁTLAG(DARABTELI(A1:F1;A1:F1))=DARAB2(A1:F1)

Angol rendszerben az argumentum elválasztót pontosvesszőről vesszőre kell cserélni.

A képlet COUNTIF (DARABTELI) része tömbképlet, ezért az egész képletet Ctrl-Shift-Enter-el kell lezárni!

Hogy működik?

COUNTIF(A1:F1;A1:F1)

Ez egy tömbképlet, ami a tartomány minden elemére megvizsgálja, hogy hányszor szerepel a tartományban, és egy tömböt ad vissza, az egyes elemek előfordulási számával. Ha minden elem egyforma, akkor mindegyik ugyanannyiszor lesz benne, tehát a visszaadott tömb minden eleme ugyanaz lesz, és ez megegyezik a tartomány celláinak a számával.

A konkrét példánál, mivel a tartománynak 6 cellája van egymás mellett, a visszaadott tömb minden elemének 6-nak kell lennie.

AVERAGE(COUNTIF(A1:F1;A1:F1))

Ha minden elem 6, akkor ezek átlaga is 6, ez pedig éppen egyenlő a tartomány elemeinek a számával. Nem marad más hátra, mint ellenőrizni, hogy a kapott érték valóban megegyezik-e a tartomány kitöltött celláinak számával. Ezt a COUNTA ( DARABTELI ) függvénnyel tudjuk lekérdezni.

A képlet TRUE/FALSE ( IGAZ/HAMIS ) eredményt ad. Lefelé másolható a többi adatsorra.

Letölthető munkafüzet

minden_elem_azonos

Videón talán érthetőbb

  • Tartomány minden eleme egyforma?

Vélemény, hozzászólás?